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1 Introduction 
 
SuperCAD/Mobile is a fully functional schematic editor that runs under Windows Mobile 
2003 or 5.0. A typical screen is shown below. 
 

 
 

1.1 Schematic editor features 
 
SuperCAD/Mobile is compatible with the desktop PC-based SuperCAD which runs on 
Windows 95/98/XP or 2000  
 

• File and library part compatible with SuperCAD V6.0 
• Schematics with sheet sizes A-E 
• Multiple sheets per schematic—up to 5 sheets 
• Easy object placement (wires, parts, and other objects) 
• Automatic connector dot placement 
• Automatic bus generation 

 
SuperCAD does not include every feature of the full PC-based program; here are some of 
the missing features: 
 

• Printing (use the evaluation or PC version) 
• Netlister (use the PC version) 
• Library Parts Editor (use the evaluation or PC version) 
• Simulation (PC version) 

 



1.2 Installation 
 
Installation of SuperCAD requires two files: 
 

• Register.bat 
• SuperCAD.CAB 

 
To install, place these files in the same directory, and start ActiveSync (which comes 
with the Pocket PC). Then click on Register.bat. This will start the Add/Remove 
Programs utility in ActiveSync and install the software. The screen is shown below. 

 
 



In the pocket PC you will get a screen similar to the following (for Windows Mobile 
5.0—you can safely ignore the message about the version of Windows Mobile, since 
SuperCAD runs on both Windows Mobile 2003 and 5.0) 
 

 
 

The SuperCAD files are installed as follows: 
 

Files Location 
SuperCAD executable, 
Title.PIC 

Program Files\SuperCAD 

Library parts (.CON files) Program Files\SuperCAD\LIB 
Audio prompts Program Files\SuperCAD\Sounds 
SuperCAD Help file Windows 
SuperCAD example files My Documents 

 
Using ActiveSync you can transfer your custom library files to the LIB directory, and 
you can transfer .PIC file to/from the My Documents directory. SuperCAD cannot open 
files in the SuperCAD directory itself. 
 
Note: you should run SuperCAD in Landscape mode. To set this mode, tap Settings in 
the Start menu and then tap on the System tab. Then tap on the Display icon. 
 

1.3 Recommended System 
 
SuperCAD runs best on the latest Pocket PC’s having a VGA resolution of 640 x 480; 
older Pocket PC’s typically have 320 x 240 resolution and should also work, but you will 
do more scrolling to view/edit a drawing. 
 



1.4 Getting Started 
 

1.4.1 Tap Operation 
 
All drawing in SuperCAD/Mobile relies on using the PDA stylus to either place objects 
or to select/manipulate them. To place objects (such as a library part or line), first select 
the object type either from the toolbar or from the Edit/Insert Object menu item. Objects 
are either placed with a single tap (text and library parts), or with two taps (lines, ellipses, 
rectangles and others). 
 
To edit single objects, first enter edit mode by tapping the Edit button (or tapping the 
Edit/Select Objects menu item). Then select single objects by tapping on them; if an 
object is selected, then object handles will be displayed. For the most part, the object 
handles are small solid rectangles located at the object stretch points. In the case of 
library parts only a dashed rectangle about the part shows when a part is selected. 
 
Note that diagonal lines can be selected by clicking at the midpoint of the line. 
 
To edit multiple objects first tap you also tap on the Edit button, but you draw an edit 
box about the objects you want to select: 1) tap at the first corner (upper left) of the edit 
box and 2) tap at the second corner (lower right) of the box; a dashed rectangle then 
shows the outline of the edit box. Make sure you do not tap on top of an object or you 
will select that object. 
 
To unselect an object or objects, tap the toolbar Edit button. 
 

1.4.2 Creating a new Schematic 
 
To start a new schematic, tap on New in the File menu. This clears the screen so that we 
can start a new drawing. If there is any work already on the screen, you will be prompted 
to save it. The default name for a new schematic is “untitled”. Change the name by 
tapping on Save As... in the File menu. Enter a name of up to 80 characters; you do not 
have to add an extension. Then tap on the Ok button. The new name will now show up in 
the SuperCAD window title bar and also in the title block of the schematic. 
 

1.4.2.1 Placing Parts 
 
The example schematic requires 6 different kinds of parts: a D74192 decade counter, a 
D7406 inverter, a resistor, a LED (diode), a push button, and a ground symbol. 
 
To load the D74192, tap on the library button . Select the GENXXX library in the 
library dialog box and select the D74192 from the part section. You will have to slide the 
scrollbar button to find the part. When you find it, tap once on it and tap on the Load 



Part button. Then place the cursor at the center of the screen and tap; the part will be 
placed there. Note that the reference designator is U1. Next load the other parts 
(GENXX\D7406, LED, PB2, HRES, and GND) and place them as shown below (in the 
completed schematic): 
 

 
 
Note that the reference designators (U1, R1, R2, etc.) of the parts are automatically set as 
you place the parts. The designator values are set by the order in which you place the part. 
For example the first resistor placed is R1, the second one placed is R2, and so on. You 
can set you own designator value for a part by first selecting the part in edit mode and 
then right-mouse tapping over it to get the edit part dialog which has a field to set this 
value. 
 

1.4.2.2 Wiring the Schematic 
 
To wire the parts together, tap on the LINE object button . Then go to the endpoint of 
each terminal that needs to be wired and draw horizontal and vertical line segments to the 
connecting terminal(s). To draw each line segment just push the left mouse button at the 
first point and then drag the new line point to the second location (and then release the 
button). Do not use diagonal lines. Connector dots are added automatically where needed. 
 

1.4.2.3 Adding Net Names 
 
In SuperCAD net names are optional, since the netlister will give each unique net a 
default net name. However, you may want to name at least some of the nets so that the 
function of a circuit is more clearly understood. For example, you may want to call a 
clock line CLOCK, and a set of memory address lines A0-A11. In the example schematic, 
we have explicitly named two nets CLEAR and VCC. To name these nets tap on the text 
button (or push the "t" key), place the cursor on one of the lines making up the net and 
tap; enter the net name (CLEAR or VCC) and then push the Esc key. You should be in 
snap-to-grid mode. 



 
Note that VCC is a standard name, which refers to the digital IC +5 power supply. 
Although you cannot see these pins on the IC's in the schematic they are in the database. 
When the netlister extracts the netlist it connects any terminals connected to a signal 
"VCC" to the IC +5 power. The same is true for signals attached to the ground symbol 
(GND part); they are all attached to the IC ground terminals by the netlister. 
 
Important Note: Use only net names with 8 or less characters and do not use any space 
characters for the name (For example, do not use CLK IN, instead use CLK_IN). 
 

1.4.2.4 Saving the Schematic 
 
After working on the schematic you should periodically save it by tapping on the Save 
item in the File menu. 
 

1.4.2.5 Using Other Features 
 
One feature that is a real labor saver when you are drawing schematics with 
microprocessors and memory parts is the automatic bus feature. Try the following 
experiment. Clear the schematic. Load the D74374 (octal register) part and place it in the 
center of the screen. Now tap on the bus object button Then tap at the point labeled p1 
(one standard grid unit to the left of the terminal--refer to diagram below). A dialog box 
will appear prompting you for a bus name and starting index. Enter "DB" for the bus root 
name and "8" for the starting index; tap on the Ok button. Now move the cursor to the 
point labeled p2 and tap. A bus, complete with "bus rippers" and signal name text will 
then appear as shown below on the right. You can draw a simple bus line (just a thick line) 
without the bus rippers and signal names by just tapping on Ok at the first-point prompt, 
and then tapping at a second point (this is how the horizontal bus segment below was 
made).  
 

 
 

2 Edit Operations 
 
You can edit in either single-object mode or multiple object mode. To edit in single 
object mode, tap the toolbar Edit button (with arrow tip on it). Then select an object by 
tapping on it.  
 



To edit multiple objects, you also tap on the Edit button, but you draw an edit box about 
the objects you want to select:  
 

1) Tap at the first corner (upper left) of the edit box (a small circle will appear to 
mark the location) 

2) Tap at the second corner (lower right) of the box; a dashed rectangle then shows 
the outline of the edit box. Make sure you do not tap on top of an object or you 
will select that object. 

 
De-select selected objects by tapping on the Edit button in the tool bar. 

2.1 Rotate 
 
To rotate selected objects through a fixed angle increment, tap over the rotate button in 
the toolbar. In single-object mode, objects are rotated by the fixed angle about their origin 
point. In group mode, the selected objects will be rotated about the center point of the edit 
box. The value for the angle of rotation is by default +90 degrees (counter-clockwise). 
 

2.2 Mirror 
 
The mirror operation works nearly the same as the rotate operation (see last section), 
except that objects are reflected about a vertical line. In the case of library parts, the 
vertical line goes through the origin. After selecting the object(s) tap on the mirror button 
to do the mirroring. 
 

2.3 Vertical Flip 
 
You can flip a single object or group of objects by first selecting the object(s) and then 
tapping on the vertical flip button. A single object is flipped about a horizontal line going 
through its origin. In group mode object(s) are flipped about a horizontal line going 
through the center of the edit box. 
 

2.4 Reference Number 
 
This operation allows you to assign reference numbers to library parts. The operation can 
be performed on one part, or automatically on every part of a selected category (for 
example, IC parts) on a given drawing page. To initiate the operation, tap over the Set 
Reference Numbers function in the Edit menu (Modify Objects section) pull down 
menu. A dialog box will then appear allowing you to select whether the operation is for 
one part or for the whole drawing page. If the whole page option is selected, enter either 
ALL or the reference letter type corresponding to the part type. For example, for ICs, you 
enter "u"; for resistors and capacitors, you enter "r" and "c" respectively. After selecting 
the category, enter a one to three digit starting reference number. All parts of the selected 



category will be numbered in the time sequence in which they were entered, using the 
specified number as a starting point. Parts with multiple components per package are 
given the same reference number until the number of components/package is exceeded; 
then a new number is assigned. Note that these parts are automatically sequenced---that is, 
in making the drawing, if you don't use the F6 key to select different instances of a part, 
this can be done in the reference numbering operation. 
 
If the operation is for one part, the part to be numbered needs to be selected. Do this by 
simply tapping over the part. After you do this, a dialog box will appear, allowing you to 
enter the desired reference number. Enter a number having from one to four digits (up to 
9999) and tap over the Ok button. The part will then be numbered, and the display will be 
updated accordingly 
 

2.5 Re-Grid Operation 
 
This operation snaps all objects to the current grid.  
 

2.6 Undo 
 
The undo operation is used to undo the last edit operation (move, copy, delete, etc.) or to 
remove the last object added to a drawing.  
 

2.7 Move 
 
To move a single object that has been selected, simply tap at the new position. Likewise, 
to move a group of objects that have been selected, tap at the new location. You can 
move multiple times by just tapping again. 
 

2.8 Stretch 
 
If a selected object has handles (e.g. the line object) , then the object can be stretched or 
resized. To do this, first tap on one of the object handles and then tap at a new position 
for the handle 
 

2.9 Inserting Objects 
 
Objects are entered with one or two taps. One tap objects include library parts and text. 
Two-tap objects include lines, rectangles, ellipses, and others. 
 



2.9.1 One Tap Objects 
 
To enter a library part, tap on the library button in the tool bar or tap on Insert 
Object/Library Part in the Edit menu. This results in the following dialog which allows 
you to select the specific part: 
 

 
 
Once you have selected a part and have clicked Load Part, you can tap at a screen 
location to place the part. To place multiple parts just repeat the tap. 
 
To place text, tap on the text button on the tool bar or Insert Object/Text in the Edit 
menu. Then tap at a screen location for the text. This results in a display of the text dialog: 
 

 
 
Enter the text and tap the OK button. 
 



2.9.2 Two Tap Objects 
 
To enter a two-tap object, such as a line, first select the object type (from the tool bar or 
from the Insert Object section of the Edit menu). Then tap at the first point and then the 
second point; if you make a mistake just tap the undo button on the toolbar and do the 
operation again. 
 
Note that a small circle will appear when you start drawing an object that uses two taps 
(such as the line); the circle marks the first tap position. 
 

3 File Operations 
 

3.1 Save and Save As Commands 
 
The Save As operation allows the current drawing to be saved in a specified file. To start 
the operation, select Save As… from the File menu; a dialog box will then appear with 
the current (default name: “UNTITLED” if you just started) filename shown in an edit 
box. If you want the default name to be the save filename, click on the Ok button; 
otherwise, enter the desired filename and then click on the button. The current drawing 
will then be saved in the specified file. 
 
If you want to save the current drawing using the current name, just click on the Save 
menu item in the File menu. 
 

3.2 Open Command 
 
To perform both directory and load operations, first access the File menu and then click 
on the Open menu item. When the Open item is activated, the .PIC extension filenames 
and sub-directory names are read from the current directory and displayed in a dialog box. 
To load a file or change a directory, first select an entry by clicking over it with the 
mouse; the selected entry will be highlighted. You can also use the up and down cursor 
keys to move through the menu items. Next, click over the Open button. If the entry is a 
filename, the associated file is then loaded and displayed. If the entry is a sub-directory, 
the current working directory is changed to this directory, and the contents of the 
resulting directory are again displayed in the popout menu. 
 

3.3 Print Operation 
 
To print a schematic, use Active Sync to transfer it to the host PC and then use 
SuperCAD (purchased or evaluation version) to print. 
 



3.4 Page Items 
 
SuperCAD/Mobile allows up to 5 pages in a single schematic file. 
 

3.4.1 New Page 
 
The New Page menu item causes a new page to be added to your schematic. This allows 
you to continue your circuit on a second page rather than create a second schematic. 
 

3.4.2 Delete Current Page 
 
The Delete Current Page menu item allows you to delete the current page of the 
schematic. 
 

3.4.3 Next Page 
 
The Next Page menu item causes you to go to the next page of the schematic. 
 

3.4.4 Previous Page 
 
The Previous Page menu item causes you to go to the previous page of the schematic.  
 

3.4.5 Exit SuperCAD 
 
Clicking over Exit in the File menu ends the current SuperCAD session. Various settings, 
including color setups, utility menu setups and others are saved in the SUPERCAD.INI 
file. 
 

3.5 View Operations 
  
Zoom In 
The zoom in operation allows you to increase (magnify) the drawing scale by one step; 
for example, from 100% to 125%. If you click on the Zoom In item in the View menu, 
the drawing is increased in scale about a point in the center of the current drawing 
window.  
 
Zoom Out 
The zoom out operation allows you to decrease the drawing scale by one step; for 
example, from 125% to 100%. When the drawing scale is decreased you see more of the 



drawing. If you click on the Zoom Out item in the View menu, the drawing is decreased 
in scale about a point in the center of the current drawing window.  
 
Center Operation 
This operation centers the viewing window over the drawing and re draws the screen. 
After this operation, the scroll bars will be centered in each of the scroll bar regions. You 
can do this operation by tapping over Center in the View menu. 
 
 

3.6 Setup 
 

3.6.1 Sheet Size 
 
To set one of the standard sheet sizes (A-E), tap one of the selections in Setup/Sheet Size 
section of the Edit menu. The default sheet size is A (8.5" x 11"). 

 

3.6.2 General Setup 
 
Tap Setup/General in the Edit menu to get the general setup dialog. This dialog allows 
enabling or disabling of the following: 
 

• Grid display  
• Title block 
• Hidden pins 
• Snap to grid 
• Rubber band operation 
• Drawing limited to orthogonal directions  
• Automatic references 

 
If the Hidden pins checkbox is checked then pin numbers are displayed on certain parts 
such as resistors and capacitors. 
 
If Automatic references is checked then, when a library part is added to a schematic, its 
reference designator (and instance letter in the case of multiple instance parts) is 
automatically set. If you don't use this feature, you can use the Set Reference Numbers 
operation in the Edit menu (Modify Object section). 
 

3.6.3 Selective Editing 
 
Tap Setup/Selective Editing to get the selective editing dialog. This dialog allows you to 
select just one type of drawing element (for example just text), or combinations of 



element types to edit. To select just one type of element, tap the No Objects button and 
then tap one of the object types check boxes. Later, when you want to select all types of 
objects to edit, get the selective editing dialog again and tap the All Objects button. 


